Ubuntu no podrá utilizarse en la Raspberry Pi

¿Por qué Ubuntu no podrá utilizarse en la Raspberry Pi?

La respuesta la ha dado nada menos que Eben Upton, uno de los dos creadores del proyecto Raspberry Pi, que fue entrevistado por la revista británica Linux User y que entre otras preguntas precisamente respondía a esa.

Estas son las palabras de Eben Upton sobre Ubuntu.

Las placas beta originales funcionaban con Ubuntu Linux, de Canonical, pero esa ya no es una opción soportada. ¿Qué ha cambiado?

Pensábamos que intentaríamos utilizar Ubuntu -que es un sistema con un aspecto muy profesional. El problema con Ubuntu, como vimos después, fue que la organización que hay detrás – Canonical – ha decidido eliminar el soporte para procesadores ARM anteriores a los ARMv7. Sólo soportan procesadores ARM de la clase Cortex, y no tenemos un procesador de esa clase Cortex, sino que trabajamos con un ARM11 [ARMv6].

Y sabes, con la mayoría de las distribuciones Linux lo que pasó es que alguien se puso en contacto con nosotros desde esos proyectos para decirnos “¿como puedo ayudaros a hacer que nuestra distribución funcione en la Rasbperry Pi?”, lo que estaba bien. Ubuntu se puso en contacto con nosotros para decirnos “¿Cómo podemos hacer que dejéis de decir que Ubuntu funciona en Raspberry Pi?”, una pregunta que de hecho pensé que era bastante brutal. Así que sí: no soportan nuestro chip, no tienen interés en soportarlo, han sido claros a la hora de intentar que digamos “Ubuntu”, así que hemos dejado de decir “Ubuntu”. Podrías ejecutar una versión antigua -Ubuntu 9.04, que creo que es Jaunty- podrías ejecutar Jaunty en la Raspberry Pi, pero no podrías ejecutar versiones más modernas que esa.

Es desafortunado, pero al menos hay una distribución que sigue manteniendo sus versiones para ARMv5/ARMv6 con vida para ayudarnos, lo que no es un ejercicio gratuito. Tenemos mucha suerte de que Red Hat haya sido tan extremadamente servicial con nosotros, pero con Canonical… Sí. Así son las cosas.

Declaraciones desde luego muy claras que confirman que las nuevas versiones de Ubuntu no se podrán usar en la Raspberry Pi.

Be Sociable, Share!

About The Author